What would be the alternative? (assuming that you want to do the loop yourself)
new_results = []
for result in results:
if result:
new_results.append(result)
results = new_results
or else
for result in results:
ifnot result:
results.remove(result)
which doesn’t do the exact same thing.
Honestly, this list comprehension is much faster to read and quite easy to understand.
I think we could rename the “result” variable “x” or “res” and it would be less confusing though.
What would be the alternative? (assuming that you want to do the loop yourself)
new_results = [] for result in results: if result: new_results.append(result) results = new_results
or else
for result in results: if not result: results.remove(result)
which doesn’t do the exact same thing.
Honestly, this list comprehension is much faster to read and quite easy to understand.
I think we could rename the “result” variable “x” or “res” and it would be less confusing though.